设为首页收藏本站
ORF反垃圾邮件系统

邮件服务器-邮件系统-邮件技术论坛(BBS)

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 8826|回复: 10

[求助] 急!! 求助: GFI MailEssentials 收进来的邮件不会转到EXCHANGE上

[复制链接]
发表于 2008-3-29 20:35:50 | 显示全部楼层 |阅读模式
I installed MailEssentials12 evaluation on a win2003 server as the gateway between my Exchange 2003 server & Internet. Before installing ME, the SMTP of WIN2003 can deliver email properly for inbound & outbound, after I installed ME, it won't deliver inbound mail to Exchange server anymore, emails are accepted and then sit in the C:\INET\MAILROOT\QUEUE folder. Recyle service or server doesn't help. I can't find any solution here, how can I fix this?
大家好! 我把MailEssentials12 (ME)装在WIN2003上, 这台机置于Exchange和Internet之间, 用IIS的SMTP, 在装ME之前, SMTP能正常地收发邮件, 装了ME之后, 就只能发邮件了(从EXCHANGE发的邮件外面能收到, 如YAHOO信箱), 外面进来的邮件(如YAHOO发过来的)ME收了后就放在C:\INET\MAILROOT\QUEUE目录, 不会转发到EXCHANGE服务器上了. 这期间没有改过任何东西, 不明白为什么邮件不会被转发到EXCHANGE, 检查过所有地方了, SMTP的设置请见以下几个图.
多谢!

[ 本帖最后由 deckking 于 2008-3-30 08:12 编辑 ]

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
 楼主| 发表于 2008-3-30 08:10:53 | 显示全部楼层

关于SMTP所有的设置请见这几个附图

关于SMTP所有的设置请见这几个附图

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
 楼主| 发表于 2008-3-30 08:11:13 | 显示全部楼层
关于SMTP所有的设置请见这几个附图

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
 楼主| 发表于 2008-3-30 08:11:33 | 显示全部楼层
关于SMTP所有的设置请见这几个附图

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
发表于 2008-3-31 12:52:16 | 显示全部楼层

Tech support to your question

There is a possibility that it was a configuration issue during installation.

My question is what mode was it installed in? SMTP, AD, or Exchange mode?

Basically i'd uninstall the product, then reinstall it. Ensure you have the lastest version from ftp://ftp.gfisoftware.com. Before installing, delete the reg entries. Also rename the mailessentialt folder. Then reinstall and ensure it is installed in the correct mode.

After this, I hope it should be okay.

If you still haven't resolve your problem, please call us at +618 8273 3000 (Adelaide Australia) for tech support or email myself at aaw@gfi.com OR support@gfiap.com.

I'll attempt to get back to you as soon as I can.

Thanks,

Alwin
Marketing Manager GFI Asia-Pacific
aaw@gfi.com
 楼主| 发表于 2008-4-1 10:41:39 | 显示全部楼层
Thanks a lot Alwin, I will restore the OS to the status before ME is installed (with GHOST img), then I will install it again. I will call you or send you email if it's still not working.

regards
发表于 2008-4-1 11:39:07 | 显示全部楼层

http://gfi.youngassn.cn/

Alternatively, you can also post your questions to GFI Chinese forum http://gfi.youngassn.cn/ in the future.

Hope your problem is resolved by now...

Regards,

Alwin
http://www.gfisoftware.cn
 楼主| 发表于 2008-4-4 23:32:43 | 显示全部楼层
Hi, thanks for the suggestion. I tried delete the remote domain and recreated it, but still no luck.

After all kinds of attemps, I ended up with rebuilding the server with the Ghost image I created before installing ME. Before installing ME, I've studied all the steps I did before and all attemps to fix the problem, I decide to take another way(approach) of installing & configureing the server.

I'd like to share my experience with everyone.

Purpose:
Setup a dedicated server for anti-spam with ME and this is the only server that opens port 25 to Internet.

Stats:
Windows 2003 Enterprise server 32bit, SMTP of IIS (No Exchange on this server)
[This server acts as gateway between Internet & Exchange 2003 server, ME & EXCHANGE 2003 are on two physical boxes]
GFI MailEssential V12 evaluation, latest version as of 2008.4.2
McAfee VirusScan 7.1 Enterprise (for OS Antivirus --- although GFI not suggest antivirus for OS level but it DOES help to protect my OS as this is the server that expose to Internet for email)

Setup:
1) During the setup of SMTP (I'm working on Win2003 server), instead of using ADD/REMOTE server roles to add MAIL SERVER,  Install IIS & select SMTP service from IIS properties.
2) After SMTP is installed, DO NOT add remote domain (the one that Exchange server hosts) as remote domain in SMTP, it will be created later during ME setup.
3) Rather than setting up SMTP connector on Exchange 2003 server to connect to ME server, I set Exchange to use ME server as a smarthost to deliver all outbound email.
4) During the setup of ME, when it prompts you for mail domain name & IP (see page 20 of ME v12 manual), type the domain name that Exchange server hosts (say, myofficedomain.com), and the IP of your Exchange server (not the IP of ME server).
5) As you typed your domain name in step 4, after ME setup is done, you will see the domain is setup as remote domain with proper IP in SMTP.
6) Modify SMTP setting to configure outbound email (for my case, I need to special my ISP's SMTP server & log in credential--they don't allow direct connect on port 25 to other servers, all mail has to go through their SMTP server).
7) Use TELNET from DOS prompt to connect to ME server and send a test mail to internal & external mailbox and check if email is delivered properly. Once it's fine, send a mail from yahoo to your internal mailbox, and vise versa, to confirm the mail flow.
8) Better to do the above change (6 & 7) one by one and testing mail flow before next change (you will need to recycle SMTP if any change on SMTP setting), pls write all your steps down as it will help you to find out which steps fails.

However, if you're luckier, you won't see my problem at all even if you followed the steps in manual (I don't mean or indicate the manual is wrong, it just doesn't work for me).

Highly appreciate the support from GFI support(Alwin for here), it helped me to understand & find out my own workaround.

GFI MailEssential is a great software for antispam, it helped me to block >95% spam emails (my ME setting still needs fine tuning).

Good luch for all..........

[ 本帖最后由 deckking 于 2008-4-4 23:33 编辑 ]
发表于 2008-5-9 11:20:13 | 显示全部楼层
Below is a list of possible causes for this problem:

1. The MX record for your domain is not configured correctly. If GFI MailEssentials is supposed to be receiving emails from the internet, the MX record should point to the IP address of the machine running GFI MailEssentials.
2. If inbound emails are passing through another gateway, ensure that you have configured the mail server running on the other gateway to forward inbound emails through GFI MailEssentials.

Please go to http://www.gfisoftware.cn or the forum of http://www.gfi.com to find out more information.
发表于 2008-7-24 17:34:29 | 显示全部楼层
偶的英文不行哪, 看不懂!
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

小黑屋|手机版|Archiver|邮件技术资讯网    

GMT+8, 2019-8-25 02:57

Powered by Discuz! X3.2

© 2001-2016 Comsenz Inc.

本论坛为非盈利中立机构,所有言论属发表者个人意见,不代表本论坛立场。内容所涉及版权和法律相关事宜请参考各自所有者的条款。
如认定侵犯了您权利,请联系我们。本论坛原创内容请联系后再行转载并务必保留我站信息。此声明修改不另行通知,保留最终解释权。
*本论坛会员专属QQ群:邮件技术资讯网会员QQ群
*本论坛会员备用QQ群:邮件技术资讯网备用群

快速回复 返回顶部 返回列表